The Galaxy Tab Forum: File transfer via USB (non-rooted tab) - The Galaxy Tab Forum

Jump to content

Welcome to The Galaxy Tab Forum

Welcome to The Galaxy Tab Forum, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information. Take advantage of it immediately, Register Now or Sign In.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get automatic updates
  • Add events to our community calendar
  • Get your own profile and make new friends
  • Customize your experience here
Guest Message by DevFuse
Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

File transfer via USB (non-rooted tab)

Posted 21 June 2011 - 02:40 AM (#1) User is offline   DeviceGuru 

  • Newbie
  • Pip
  • Insert nick to fast reply form
  • Quote selected text to fast reply form
  • Group: Members
  • Posts: 1
  • Joined: 21-June 11

hi all,

I've been getting to know my Galaxy Tab 10.1 for the past week. It's the standard GT-P7510 running Android 3.1, non-rooted (scared to break it at this point!)...

My PC is running Ubuntu 10.10, and I'd like to do file transfers to/from the tab, accessing it like a USB drive. When I plug the Tab's USB inteface cable into the PC, a USB connector symbol message takes over the Tab's screen, indicating that it's connected (it also says "Press the home key to quit Samsung Kies"). At the same time, on my Ubuntu desktop a "camera" icon labeled SAMSUNG_Android pops up.

At first when I clicked on the camera icon on the Ubuntu desktop, it tried to access it via Open Shotwell, which is Ubuntu camera interface program. So I disabled automatic access by that app, using Ubuntu's utility to set what apps run automatically when you click on folders or files.

After doing that, I can browse folders on the Tab's sdcard by clicking the camera icon on Ubuntu's desktop. I can now create new folders on the Tab's sdcard, transfer files to it, delete them, etc. And after I disconnect the USB connection, I can see the folders, files, etc. on the Tab that I transferred to it over USB.

But -- and this is the weird part -- although the files or folders I created over USB can now be accessed from the Tab (using a file manager app), once I disconnect the USB connection to the PC I can't access it again from the Ubuntu system following reconnect.

Anybody have any idea what's causing this weird behavior?

Thanks!
Rick

Remove Advertisements User is offline Advertisements

  • TheGalaxyTabForum.com



Posted 29 December 2011 - 05:31 PM (#2) User is offline   martinman 

  • Newbie
  • Pip
  • Insert nick to fast reply form
  • Quote selected text to fast reply form
  • Group: Members
  • Posts: 2
  • Joined: 29-December 11

I've had 0 success getting my galaxy tab 7.0 plus to mount on my ubuntu box, although my mswindows work computer mounts it just fine. I've been here
http://forum.xda-dev...d.php?t=1077377
and here

http://www.xoomforum...age-ubuntu.html

and here

http://lifeafter2am....-10-1-to-linux/

thru all this I find that "gmtp" should work, but it does not. I've upgraded from my earlier l<something> build of ubuntu, thru maverick, to natty, to where I am now, o-<something>, v 11.10 I believe it is. The xda link above seems to have the most reliable info, for those of you attempting any of this.

I'm still looking for a solution. so any help would be appreciated.

Posted 29 December 2011 - 07:05 PM (#3) User is offline   wizz 

  • Superman Moderator
  • Insert nick to fast reply form
  • Quote selected text to fast reply form
  • Group: Super Moderator
  • Posts: 5,584
  • Joined: 09-December 10
  • LocationUK
  • Device Size:7-Inch Original
  • Device Model Number:GT-P1000
  • Android Version:2.3.3 Gingerbread

View PostDeviceGuru, on 21 June 2011 - 02:40 AM, said:

But -- and this is the weird part -- although the files or folders I created over USB can now be accessed from the Tab (using a file manager app), once I disconnect the USB connection to the PC I can't access it again from the Ubuntu system following reconnect.

Anybody have any idea what's causing this weird behavior?

Thanks!
Rick

Sounds to me like all you have transferred over are Short-cuts of those Files and Folders...

If you've "dragged & dropped" ......try using "copy & paste".....
Posted Image

Galaxy Tab 7" wifi & 3g (GT-P1000) Gingerbread 2.3.3
Galaxy Tab 3 8.0 wifi (SM-T310) Kitkat 4.4.2

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic


1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users

IPB Skins by Skinbox

Skin and Language