The Galaxy Tab Forum: SIM card does not fit snuggly enough in my 7.0 plus' slot? - The Galaxy Tab Forum

Jump to content

Welcome to The Galaxy Tab Forum

Welcome to The Galaxy Tab Forum, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information. Take advantage of it immediately, Register Now or Sign In.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get automatic updates
  • Add events to our community calendar
  • Get your own profile and make new friends
  • Customize your experience here
Guest Message by DevFuse
Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

SIM card does not fit snuggly enough in my 7.0 plus' slot? Are all SIM cards made the same?

Posted 27 March 2012 - 04:07 AM (#1) User is offline   Tankchua 

  • Newbie
  • Pip
  • Insert nick to fast reply form
  • Quote selected text to fast reply form
  • Group: Members
  • Posts: 2
  • Joined: 26-March 12
  • LocationAustralia
  • Device Size:7 Plus
  • Device Model Number:Unknown(SAD) - See : Settings, About Device
  • Android Version:Unknown(SAD) - See : Settings, About Device

Have my 7.0 plus since last Xmas and had it fitted with an Amaysim SIM from day one. Worked fine for 2 months but since last month, the Tab occasionally displayed 'no signal' where the 3G signal bar usd to be (bottom right corner) and when I checked the mobile network settings, it has the message 'please insert SIM'. The solution then was to restart the device and I will have 3G signal again.

For the last 2 weeks, restarting the device does not solve the problem. I'd removed the Amaysim SIM and replaced with another SIM by the same operator with no change in outcome. Another SIM but by Vodafon got me my 3G signal back! Short lived euphoria - Vodafon SIM similarly stop working after a couple of hours. Restarting Tab does not help but exchanging the SIM with that from Amaysim get me another couple of hours of 3G signals. Yesterday, after getting inspiration from some related topics on this forum, I slipped a strip of cardboard behind the SIM, a strip long enough to allow me to pull it out but too long to allow me to shut the SIM card slot, 3G signals has been maintained since. I obviously do not want to continue from this point on with a stip of cardboard sticking out from my Tab, is there a permanent solution to this? From the story above, is a loose SIM card the only possible cause of my Tab's problem?
Don't Be ..... Unknown(SAD)


Please Edit your Profile


Galaxy Tab Model : 7 Plus
Galaxy Tab Number : Unknown(SAD) - See : Settings, About Device
Android Version : Unknown(SAD) - See : Settings, About Device

Remove Advertisements User is offline Advertisements

  • TheGalaxyTabForum.com



Posted 27 March 2012 - 07:20 AM (#2) User is offline   Moderator Blast 

  • Lady Super Moderator
  • Insert nick to fast reply form
  • Quote selected text to fast reply form
  • Group: Super Moderator
  • Posts: 3,653
  • Joined: 10-December 10
  • LocationKent UK
  • Device Size:I have more than one device. See my Signature
  • Device Model Number:See my Signature
  • Android Version:See my Signature

Hi Tankchua, to the best of my knowledge we haven't heard of this problem before in the forum. We have seen issues with the SD card being lose but not the Sim. It sounds like the spring mechanism is ejecting card cards, so I would say that if you are 100% sure you are pushing it in all the way, then you may have a fault, possibly with the connections or spring.
No problems with my VF PAYG so far.
Posted Image
Posted Image
GT5100 Note 4.1.2 (2013) -- GT-i9300 4.3 JB (2012) -- GT-P6200(IR)3.2 (2012) -- GT-P1000 Overcome Rom 4.1 GB 2.3.6 (2010) -- Kindle (2011)

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic


1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users

IPB Skins by Skinbox

Skin and Language